Thermal Bridge Heat Transfer & Vapour Diffusion Simulation Program AnTherm Version 6.115 - 8.133 

[ ← ] [ ↑ ] [ → ] [ToC]

Export image to file

Graphical images can be saved to image files (PNG, TIF, JPG, BMP, GIF).

The button „Copy Image“ and the menu „File→Export→Image“ (or „Edit→Copy Image“) provide the transfer function of the picture prepared within a 2D or 3D view to the clipboard and/or to image file.

Important: The 3D image will be always recreated in specific, defined size and on top of white background thus being better suitable for printing.

Remark: This function is available if there is 3D graphical window active (Elements3D, Results3D).
Export of 2D views is offered if there is a 2D window active (e.g. Elements2D).

Remark: Graphical views can be transferred to other applications as images via the clipboard also.

If the application setting "clipboard image Save-To-File option" is set to active (true) then you will be offered an option to save (export) the image into an image file (PNG, TIF, BMP, GIF, JPG) - a file-save-as-dialog will be presented.
Lately chosen export format will be initially offered.

When save operation is repeatedly used the index file name will be offered. If the name recently used ends with digits, then the numeric pattern of same length will be created (Name_0001, _0002 a.s.o.). If the recent name does not end with digits, then a three digits long index will be offered.
Important: The new free index will be used, i.e. if recently Name_0005 has been saved, but yet Name_0001 does not exist, this Name_0001 will be proposed followed by _0002,_0003,_0004 and later _0006, ....

Remark: The option to save images placed onto the clipboard to a file can be set within application settings (Clipboard image Save-To-File option, AlwaysAskToSaveGrabbedImage).

Remark: The meaning of the setting "Clipboard image Save-To-File option" can be reversed while the SHIFT-key is held depressed during a click onto the "Photo button".  This means, that if the Save-To-File option is active saving the image to the file will not be offered if the Photo-button is depressed during the SHIFT-Key is held depressed. Opposite is also valid: During the Save-To-File option is not active (set to False) and the Photo-button is clicked while holding the SHIFT-key, the dialog offering saving of the image to a file will be presented in contrast.

Dimensions of the image created for 3D views

Important! Dimensions of the image of a 3D view transferred are not equal to the size of the image visible on the screen!

According to the application wide dimension setting the image will be created at defined size (within "virtual“ window) and transferred thereafter. The size and proportion (aspect ratio) of the image specially created for the file storage can be set within application settings.

The input describes the resulting image dimensions in pixels (image points).

Keep View Aspect Ration - application setting

If proportions of the image visible in the window on screen differ from proportions at which the image shall be transferred (i.e. different ratio of width and height) the resulting image transferred will display differently then that on the screen!.

This results from the binding of scaling of the displayed 3D view to the window height:

  • try changing the height of the window – 3D object shown will scale accordingly also.
  • changing the width of the window does not influence the scaling of 3D objects shown!

This automatic scaling behaviour of the image can be suspended for the image being transferred by the setting „Keep View Aspect Ratio“ – transferred image will be created at one dimensions actually smaller as set in parameter to show at same aspect ration as the view on the screen.

See also: Elements 3D, Results 3D, Application settings, Menu File→Export→Image, Menu Edit→Copy Image, Copy image to the clipboard, Keep View Aspect Ratio (setting)


 Model, Calculate, Simulate and Analyse Thermal Heat Bridges in 2D and 3D with AnTherm®  

[ ← ] [ ↑ ] [ → ] [ToC

 Copyright © Kornicki Dienstleistungen in EDV & IT

2017-03-22 10:19 +0100