Thermal Bridge Heat Transfer & Vapour Diffusion Simulation Program AnTherm Version 6.115 - 8.133 

[ ← ] [ ↑ ] [ → ] [ToC]

Working with files

The software saves data entered by the user as well as calculated intermediary results into different, project specific, files and folders.

Project files

Data of each project is stored in so called "project files". For all project files the software expects and uses the file name extension ".antherm". It is under users' control choosing some different extension for certain purposes instead of the extension (".antherm") suggested by the program.

The name of the project file must be unique within the folder it is saved into. Of course it is allowed to have project files with equal names saved to different folders.

For the purpose of Data backup it is absolutely sufficient to make secure copies of project file. All data and settings required to reproduce any calculation results (even if requiring complete recalculation) and all project specific parameters are kept in the project file.

Project file stores following data - provided this data has been entered:

The file name extension ".antherm" is signalling to the operating system, that it is the input file for AnTherm. A double click onto an AnTherm project file starts the application and loads the chosen file.
Remark: Also dropping (drag & drop) a project file over the main application window will open that file.

Opening or saving of project files is executed from the menu "File". All project data is also saved automatically at the beginning of each new calculation run or new evaluation. At any time project data can be saved by choosing the menu File→Save... . This is especially useful during evaluation to save current boundary condition for example too..

The software will offer the option to save data prior to any potentially destructive operation. This "safety" behaviour can be turned off in application setting by changing the value of the option "always ask to save project".
It is recommended to save project data before executing following actions:

Remark: During the initial save operation the application will create the standard project folder and offer this in respective dialog as central storage point for project files. The name of this folder is defined by the application setting "Default project directory".

Important: The overall path length of a project file (i.e. including drive and folder names  L:\folderpath...\projectfile.antherm) is constrained by operating system limits. When the current limitation of Windows is taken into account together with path lengths required for the folder of simulation results and its contents the maximum path length of a project file must not exceed 220 characters. Simulation results will not be created if the path name is longer then 220 characters - the project has to be saved under different name or into different folder (with overall path length not exceeding 220 characters) to be able to obtain simulation results also.

Folder of simulation results

For each project AnTherm keeps tentative calculation results (simulation results) of calculations stored in a subfolder "<projectfile>.dir".
This means, that for a project file named <name>.antherm there will be a subfolder <name>.antherm.dir storing simulation results. The project file and the related subfolder of simulation results accompany each other and therefore they share the name.

The absence of a simulation folder signals, that there has been no simulation run yet. If the folder <name>.antherm.dir has been deleted by the user then, on the next request to show results of the project <name>.antherm, complete calculation run will be executed. Deleting the simulation folder can therefore be used to force full recalculation. Since all data required for reproduction of simulation results along with all project specific settings are kept in the project file, the loss of simulation folder does only mean, that additional time is required to repeat all the required computations.

Contents of the simulation folder "<projektdatei>.dir" are fully managed by AnTherm - without any intervention required from user. The simulation results folder has special, application specific, structure and thus it is not designed to be accessed by the user directly. AnTherm creates this folder and, under certain circumstances, will purge its contents also without warning. For that reason no user specific files or data shall be placed into the folder "<projektdatei>.dir" ! Manipulating contents of the simulation folder might also break its data integrity leading to serious software malfunction - therefore it is forbidden!
To avoid accidental manipulation AnTherm applies hidden attribute to each simulation results folder. This makes this folders invisible and unavailable for browsing within windows file explorer by default. Only if the user changes the setting "show hidden files and folders" within windows file explorer, simulation results folder will be shown therein. This specific setting of windows file explorer does also apply to results shown in the dialogs "Open project..." and "Save project".

Note: Simulation results of a vapour diffusion computation also stored as a subfolder DAMPF within the simulations results folder "<projektdatei>.dir".

For the purpose of Data backup it is under users control to save simulation results folder also - in addition to project file. If the project file <name>.antherm and its accompanying simulation results folder <name>.antherm.dir are together restored, the application has no further need for full computation of simulation results.

The Simulation folder cleaner tool supports you in removing (physically deleting) unneeded simulation results folders to save disc space.

Important: Calculation of a project with its name given by a UNC name (e.g. \\server\path...\project.antherm) is not allowed. If the given UNC path name cannot be coupled with a temporary network drive the application will show explaining message accordingly. In general the calculation of a project on a network drive (connected by a drive letter) is possible but (due to significant performance penalties) not advisable.

Variant calculation, renaming and copying of project file

Under certain usage scenarios there might be the need to execute calculation of variants which differ only slightly by few parameters. In such a case it is the easiest to simply save the project with new name. However this results in the need of complete simulation calculation because the simulation folder does not exist yet for the new project name.

Remark: The need for performing complete new simulation calculation results when significant input data or parameters of s project have changed: e.g. geometry of the construction, material and/or surface properties, names (tags) of spaces, power sources, materials or surfaces, fine grid parameters etc. This concludes that only under very rare occasions there will be no need for complete new simulation calculation to be executed.

Still to avoid repeating simulation calculation when performing variant modifications one can copy the project file and its accompanying simulation results folder with simple tools of the operating system (e.g. windows file explorer, command line etc.):

Variant scenario A:

Use subfolders to store variants: copy the project file <name>.antherm and its accompanying simulation folder<name>.antherm.dir into a new folder. That way you receive a subfolder "Variant B" containing equally named copy of already calculated project and its simulation results from folder "Variant A".

Variant scenario B:

Make a copy of the project file <nameA>.antherm and name it <nameB>.antherm. Make a copy of the simulation folder <nameA>.antherm.dir also and name it <nameB>.antherm.dir. That way you have an exact copy of project "nameA" and its simulation results folder, now both named "nameB".

Miscellaneous files

Beyond project files the application stores further information in additional, application specific, files:

This application is aware of importing files created with other applications:

There are some example project files included with the application's installation which can be used to execute tutorials and learn the program's use. These example project files can be found in the subfolder "Beispiele" (means "examples" in german) of the installation folder (typically  C:\Programm\tkornicki\AnTherm\Beispiele) or can be directly loaded into AnTherm via the menu Help->Example Load... .

Results created with the application can be exported for further processing:

See also: The main menu, Tutorials and cookbooks, Simulation folder cleaner


 Model, Calculate, Simulate and Analyse Thermal Heat Bridges in 2D and 3D with AnTherm®  

[ ← ] [ ↑ ] [ → ] [ToC

 Copyright © Kornicki Dienstleistungen in EDV & IT

2017-03-22 10:19 +0100